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Projet

me

Etudier la rupture d’un lac d’accumulation pour la production de neige artificielle, dont

les caractéristiques

e volume : 46 000 m?

» cote du fond 2020 m

* niveau des plus hautes eaux 2030 m

o cote de la créte du remblai 2032 m
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Données de base

o e
On dispose des données suivantes

 orthophotoplan (ortho)

e scan de la carte IGN (scan)

e modele numérique de terrain (MNT) au format SHP (cbntot), obtenu par
photorestitution

» modele numérique de terrain au format ASC (raster), obtenu par interpolation
linéaire

» orthophoto plan avec vue du projet (vue au format tif ou jpg)

» projet de digue en remblai (retenue) au format SHP

Le systeme de georéferencement est EPSG 27562 (Lambert Centre) adapté pour la

France (le projet est en Savoie).

Au choix, on dispose d’'un MNT au pas de 5 m (généré par Blender) et appelé
«MNTStFl.asc» et un autre avec une maille rectangulaire 10 X 5,33 m (génére par Qgis).
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Qgis

e

Sous Qgis (https://www.qgis.org/fr/site/), I'ajout des couches donne cela :
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Import de la géometrie

e

Comme pour tous les codes de calcul numériques modernes, I'utilisation d’lber se fait

classiquement en suivant trois étapes :

1. on commence par sauver le projet en lui donnant un nom : Files > Save

2. oncharge le MNT avec la commande Iber Tools > RTIN > Create RTIN. Dans la
fenétre on entre les parametres : tolerance -> 0.5 (tolérance en m entre la grille
genérée par Iber et les points du MNT importé) Maximum side ->50 (taille
maximale d’'une maille en m), et Minimum side -> 5 50 (taille minimale d’'une maille
en m) Create RTIN File a8

Original DTM File  |toponn5m.asc Retrieve |

Importas (% Geometry ( Mesh

Tolerance |0.5
Maximum Side 50|

Minimum Side 2

Accept | Close |
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Creation de la geométrie

e

Plusieurs fenétre s’affichent cela peut prendre du temps... 1 a 5 min selon la puissance
de la machine. Répondre oui aux questions posées.

% ERa64 Project: projet 8

R T L R T e T EAL ]
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o e
IR AT Created [
5@ New RTIN file was created. Now
e W itvill be imported.
%‘ o
o
118
K
<
®l
Geometry was successfully
collapsed. Do you want to mesh
= the geometry?
5 ; .
Yes |
) -
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Creation de la géométrie

e

On se retrouve avec une image assez dense... On peut charger I'orthophotoplan avec View
>Background image > Real size avec le grand orthophotoplan «ortho.tif»

Files View Geometry Utilities Data Mesh Calculate Iber Tools Help
COSIBRED I BRIPD Lo -sle? 9 o
£ e

-

Enter 1st point 2 x=91735e+05
Enter 2nd point =
nter 2nd point = 53648

Command: &+ =0
Zoom: 1.0x Nodes: 127503, Elements: 253440 Render: Normal (9.1735e+005,53648 ,0) Pre
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Creation de la geométrie

e

Un agrandissement montre un réseau dense de triangles (d’ou le nom : RTIN =
Rectangulated triangles irreqular network)

% IBER x64 Project: projet (BER) E=REEN_* ]
Files View Geometry Utilities Data Mesh Calculate Iber Tools Help
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-S| @24 Yber e
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]

2 x=9173e+05

. y=55292

Command; &+ =0
e

Zoom: 1.0x MNodes: 127503, Elements: 253440 Render: Normal (9173e+005,55292 ,0) Pr

Enter 1st point
Enter 2nd point [
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Creation de la geométrie

e

En cliquant sur View > Render > Smooth, vous aurez un rendu de la surface. Notez le lac de
retenue en haut a droite. Les couleurs ne sont pas tres belles...

:' SER s Bt ﬁim‘b—“ﬂg

Files View Geometry Data Mesh Calculate Iber Tools Help
-S| &2 ¥

OEQI{:&? |ﬁ=‘.[QQ& Layer

D]
HEORTOSHBY B

Leaving boundary draw. * x=91672e+05
mode has changed L |
9 _ y=53550

Command: a =+ =0
Zoom: 1.0x Nodes: 127503, Elements: 253440 Render: Flat (9.1672e+005 53559 ,0) Pre
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Creation de la geométrie

e

En cliquant sur I'icone «Layer» vous pouvez modifier la couleur et la transparence (couche
Dxf)

% IBERx64 " Project: projet (IBER)

Files View Geometry Utilities Data Mesh Calculate Iber Tools Help

- Sz 2 | ¥

\

N || Double click here to integrate the window

Layers |Groups|
BKEABT

icone «layer»

—/{( Neme ¥ C U0 FU Tr B ETEE
= Dxf ¢V & B EEEEEN
‘l Layedd v v & B HEE=

User colors

[

Red: 153 99
Green: 122 7a
Blue 97 61

Opacity: 255 -

U

mode has changed * x=91418e+05
Z]

‘Choose option : y=54309
Wy
Zoom: 1.0x Nodes: 127503, Elements: 253440 Render: Flat (91418¢+005,54909,0) Pre
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Creation de la géométrie

e

Avec l'outil rotation, vous verrez une vue 3D... et les défauts du raster : la maille utilisée est
trop petite par rapport a la densité des points de la restitution photogrammeétrique, ce qui
génere des terrasses.

S .

|5 merass Project: projet (IBER)
Files View Geometry Utilties Dats Mesh Calculste lberTools Help

OO BEED B DP e fR IR R AR Vber s

outil rotation __
pour revenir a une

vue plane, clic-droit : :

[ Double click here to integrate the window

de la souris > Plane
XY (Original)

Pick LEFTMOUSE to desplace view (ESC to quit) £ x=9.1781e+05
S

Pick LEFTMOUSE to desplace view (ESC to quit). I,

Command: oW E =0
Zoom: 1.0x. Nodes: 127503, Elements: 253440 Render: Flat (9.1781e+005 54501 ,0) Pre |
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Entrée des conditions aux limites

e

Pour la condition aux limites de sortie, on va sélectionner tout le cadre du domaine. Pour
ne visualiser que ce cadre (et pas des éléments internes au domaine), on clique sur Mesh
> View mesh boundary. Cliquez sur Yes quand la fenétre vous demande s’il faut maintenir
le cadre. Vous ne devriez alors ne voir que la frontiére du domaine (pour mieux voir,
enlever la photo de fond dans View > Background Image > Show).

3 IBER x64 Project: projet (IBER) [E=REClT ]

Files View Geometry Utiities Data Mesh Calculate Iber Tools Help
0O VERL | BR DD o -S|l 27 Y Yber e
© @

Ly | & (‘. ‘ > -'_'\‘

L HBOETO SR B PRSP b9

.

Mantain Boundary visuzlization after leaving function?
T

© see all mesh use this function again

Comman: d | &+ =

Zoom: 1.0x Nodes: 127503, Elements: 253440 Render: Normal (9.143e+005,52781 ,0) Pre
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Entrée des conditions aux limites

e

Dans Data > Hydrodynamics > Boundary conditions, choisir «2D outlet» dans l'onglet.
Laisser «Supercritical/critical» comme CL. Puis cliquez sur le bouton Assign. Encadrez alors
tout le contour et cliquez sur ESC pour finaliser la sélection. En cliquant sur Draw > Color
pour vous assurer que tout le cadre a bien été assigné.

SuoiThnt @nlon - elurla : ~=| Pour faire
“;’; - réapparaitre les
(’ = éléments, il faut
— w2 ‘ revenir sur la
commande Mesh >
: View mesh
] boundary et cliquer
f cette fois-ci sur
«No».
(i ¥ SUPERCRITICAL/
f_._.?’ L. DEELZ'TJS?Z.G
Command: @+
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Entrée des conditions initiales

e

Pour assigner les conditions initiales, on supprimer le rendu (View > Render > Normal) et
on charge l'orthophotoplan «vue.tif» qui montre le projet. On peut jouer sur la
transparence de la couche pour mieux voir.

1Y merx6e Project: projet (BER) ESRRCAC <)
Files View Geometry Utilities Data Mesh Calculate Iber Tools Help
-S| 22|94

o LR ad BB e

wber VEFSION 2

On clique sur Data >
Hydrodynamics >
Initial conditions,
: L; | puis on choisit
I'option «elevation»
et on fixe la cote de
la surface libre a
2030 m.

SORPARNT TN

212N IBAIC

[Enter 1st point
Enter 2nd point

Command: “ + z=0
Zoom: 1.0x Nodes: 127503, I 253440 Render: Normal (917234005 55263 0) Pre
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Entrée des conditions initiales

e

Les trois formes en haricot les plus petites correspondent aux cotes 2020, 2025, et 2030
m. On sélectionne donc tous les éléments a I'intérieur. Avec le clic droit de la souris on

peut sélectionner les options «add to selection» ou «remove from selection».
(14 R s Project:projet (1BER) L= | B

Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help
.s|®2 |9 R e

CPARERP|BE|PD Lo

o e N .
ptC A la fin, on tape sur
ad .
o= «ESC», puis on peut
e !- ‘ - | vérifier avec Draw >
R L Ml | Color que I'on a tout
g o bien sélectionné.
Wi
=
&, K
oR
ks :
2020 m
2025 m
2030 m

% x=91722e+05
. y=55250
Command: |+ =0

Zoom:; 1.0x Nodes: 127503, Elements: 253440 (9.1722e+005 ,55259 .0) Pre

dded 4 new elements to the selection. Enter more elements. (ESC to leave)
dded 16 new elements to the selection. Enter more elements. (ESC to leave)

Render: Normal
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Entrée des conditions initiales

e

On voit qu’il y a des trous. On recommence en sélectionnant les bouts manquants.

4 IBER %64 Project: projet (IBER) &

Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help

ColdlLilad|da e w0 -S| 22 € Yber s

*\ ?I 2D Initial Condition

C~) Water Elevation -
6 ﬂ
Elevation [m] 2030

[ Etevation 2030 0.0

Now on, conditions will be drawn by color £ x=91722e+05

press "escape’ to leave 5. y=55264
Command: i + z=0
) Zoom: 1.0x Nodes: 127503, Elements: 253440 Render: Smooth (91722e+005 55264 ,0) Pre j
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Entrée des conditions initiales

e

Le résultat est plus satisfaisant.

% IBER x64 Project: projet (IBER) =B ]

Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help

Co|R@Rd | B DD Ly -S| 229 Yier o

\

"\ 41l 20 Initial Condition
\) Water Elevation -
4

Elevation [m] 2030

|

)

& &

{ilr

= T aw
Press 'Finish’ to end selection

Close

[ Etevation 2030 0.0
Now on, conditions will be drawn by color ' ' : ' % x01717es05
‘escape'to | El
press ‘escape to leave L I
Command: . ‘+‘ =

Zoom: 1.0x Nodes: 127503, Elements: 253440 Render: Smooth (91717e+005,55257 ,0) Pre
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Creation du maillage

e

On va dans Iber_Tools > Mesh > One element by surface. Au bout de quelques secondes,
cela a généré le maillage. On en profite pour recharger 'orthophotoplan si 'on veut.

Y IBERx64 Project: projet (IBER) =8 8 |

Files  View Geometry = Utilities Data  Mesh Calculate Iber Tools Help

0O DBRD | BE|RPD o -sle2ld

S
l@rnio | Ne

VAR

OW)
AA

M@

Time Parameters | General | Results | Custom Hazard Sedi | Breach | Water Quality |

Simulation New
Initial time [s] 0
Max simulation time [s] 600

QB4
kRN

Results time interval [s] 10
Time Options Not Show ~

Tk
5

HBO™TQ S aig ki

%‘D:fQGrs_TDIonhu.tif‘ will be used a: : %=9.1501e+05

j mage georeferentiated. %‘ y=55178

Command: &+ =0

Zoom: 1.0x Nodes: 127503, Elements: 253440 Render. Normal (9.1501e+005,55178 ,0) Pre

B ENACILHE | 2017 18

ECOLE POLYTECHNIQUE
FEDERALE DE LAUSANNE




Entree de la rugosité

e

On agrandit |la vue, puis on clique sur Dates > Roughness > Land use. On choisit en
premiére approximation «brushland» n = 0.05 (K = 20 m1/3/s). On peut affiner selon les
secteurs, mais ici a des fins d’illustrations, on fait au plus simple. On assigne tous les

7 14

éléments.
% IBER x84 Project: projet (IBER) = B %)
Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help ]
COS|REEG | @R e -Sl22 4 Yoer Tomes
P e f

o
&3

L —

Al oo B & A Toar

[HBOMHES Hw

Enter elements to assign to Material: brushland * x=91445e+05
‘Added 253440 new elements to the selection. Enter more elements. (ESC to leave) El 55682
- Y=

Command: @ 4 =0

Zoom: 10x Nodes: 127503, Elements: 253440 Render: Normal (9.1445+005 ,55682,0) Pre
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Données geneérales

e

Dans Data > Problem data, on met (p. ex.) un temps de 600 s et on sauvegarde les
résultats toutes les 10 s. On laisse le reste identique (on peut s'amuser avec les options
apres) sauf 'onglet «Breach».

% IBER x64 Project: projet (IBER) =8 8 |

Files  View Geometry = Utilities Data  Mesh Calculate Iber Tools Help

CoB TR D BE|RE we -sle2ld

PARTY-I 0L
Al@Grhie | Ke

St
e w2 @

e Time Parameters | General | Results | Custom Hazard Sedi | Breach | Water Quality [W

‘! Q Simulation New
== [ Initial time [s] 0
- Max simulation time [s] 600
‘;‘é Results time interval [s] 10
4

Time Options Mot Show  +

HBO™TQ S aig ki

“D:fQG»s_TDIonhu.tif‘ will be used a: * x=91501e+05
j}mlg: georeferentiated. % y=55178

Command: &+ =0

Zoom: 1.0x Nodes: 127503, Elements: 253440 Render. Normal (9.1501e+005,55178 ,0) Pre
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Saisie des conditions de formation de breche

e

Dans l'onglet «Breach», on active 'option «Breach Formation».

%} IBER x64 Project: projet (IBER) o B %

Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help

0@9|Q@f‘%‘{*fﬁ#| Q% Layerd

-S| %2 |49 Yber oo

=) Time Parameters '\General Results | Custom Hazard | Turbulence | Sediments \En:rnachmen{ Breach ‘Watef Quality L’J

Breach Formation Enabled  ~

[BO™F QO HeRA

:Géﬂing point from element 5401 T ” x=91723e+05
iPoint number -. Coords x=9.1706e+05 y=55364 2=2012.5 . Enter more points (ESC to leave) £ 55264

-~ ¥=
Command: . —i' =0

im:m: lbx Nnd’cs: 1275!;3, Elemtnﬁ: 753446 k:ndcr VI;IormaI (9i7é§e+ 6(;5 ,55264 ,d)r Pre
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Saisie des conditions de formation de breche

On zoome sur le lac de retenue (avec «vue.tif» en arriere plan), puis on va dans le menu Data

> Breach > Breach definition, on entre le niveau des plus hautes eaux (2030 m), la cote du
fond (2020 m), le volume du lac 46 000 m3 (=0,046 hm3). On laisse le reste inchangé.

pour en savoir plus sur le guide technique espagnol, voir p, 20
http://www.mapama.gob.es/es/agua/publicaciones/guia_planes_emergencia_tcm7-28835.pdf

[5 meR e Project: projet (BER) - l=E
Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help
CoR | BRRd B8P weo - & | #2|4 Yoo Toms

création <

d’un bréche e
Al 12, a Time -

= R

/ SR e
Saisie des i
coordonnées de
la bréeche

7

[|BOEES S

[Getting point from element 5401 A 4=01715e+05
Point number -, Coords x=9.1706e+05 y=55364 z=2012.5 . Enter more points (ESC to leave) (=) o
~ ¥=
Command: &+ 2=0

Zoom: 1.0x Nades: 127503 Flements: 753440 Render: Narmal (917156+005 55279 O Pre
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Calcul

e

On lance le calcul depuis Calculate > Calculate (ou bien en pressant la touche F5). On peut
suivre les résultats en lancant la fenétre Calculate > View process info. Notez que le volume
initial calculé par iber est un peu trop petit. Une fois le calcul fini, on bascule dans la phase
de post-traitement (cliquez «Yes» a l'invitation ou bien sur I'icbne dédié).

40.%
50.%
60.%
70.%
80.%
90.%
100.%

VOI u m e NUMERICAL SCHEME: Roe 1st Order

Initial volume: 38202.92 m3

initial bibhes e Wit ik

0.000 1.00000 17:10:30:84
10.053 0.07401 17:10:34:53
20.002 0.0804% 17:10:38:08
30.033 0.082865 17:10:41:66
40.069 0.09610 17:10:45:08
50.097 0.10548 17:10:48:36
60.040 0.12231 17:10:51:53
70.067 0.12248 17:10:54:67
80.041 0.12540 17:10:57:78
90.057 0.12944 17:11:00:89

100.026 0.12866 17:11:04:00
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Post-traitement

e

On peut alors étudier les résultats dans Iber ou les exporter. Avec Window > Animate, on
peut voir I'évolution des zones inondées

§ IBER x64 Project: projet a0 =

Files View Utiities Docuts Viewresults Options Window Iber_Tools Help

Powd|RER40|8s oSS o 2 (4

o e
P
B
2 a ILE-..
=
FENE
_E N
w LN
T x*;;
Xy @
ﬂﬂt 3
e -
PR S
= I L3
A
ot
g =
i U
—
== @ Optiens
A 1= 9] Results View
_2' @‘ [7] Automatic Limits = :
animati
I ] Deformation B
g ) Endiess
n [”| From step |1 to step 61
“ Set duration by:
) Total Time: |5 5
[7] use step values as scaled delays
© Delay between steps: 200 ms,
7 Use step values as seconds
Play
Step number: 34 Step value: 3300 00:00
EL]
B i
Save image Depth (m)
[Z] Save |PNG 6.8763
6.1134
5.3505
Save animation - 4.5875
[C] Save | AVI/MS Video 1 ~lon @ 3.8246
Create a stereoscopic animation 3.0617
22988
1.5358
[porn (o] orrzm
| 0.010002
-—
Hydraulic, step 330
Smoath Contour Fill { Mean) of Depth (m).
Maximum value reset. 0163508
Smooth Contour Fill { Mean value) ‘Depth_(m)': Min = 0.010002, Max = 68763 (=
= y=53810
Command: &+ =0
SE—— [01A25aamns S2RIN M Dnet

I
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Post-traitement

e

Avec l'outil Do Cuts > 2D Polygonal Cuts, on sélectionne deux points (ESC pour sortir) au
niveau du village pour avoir I’'hydrogramme. Attention ! Il faut sélectionner le premier point
en rive gauche, le second en rive droite (donc ici, le premier point en bas, le dernier en

haut) pour respecter le sens d’intégration. Sinon on obtient des débits négatifs (en soi, ce
n‘est pas trop grave).

LGl L
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Post-traitement

e

Voila par exemple ce qu’on obtient si on ne respecte pas cette convention.

Plot graph | Create | Graph Set Options | Graph Management
Specific_Discharge_(m2/s)

.
O u t I I E 0 graphset-2
= —*— Integral of "Specific_Discharge_(m2/s)' over 'CutWire 1 Dxf'

hydrogramme N

-10.4

-15.6

-20.8

-26

540 600
Time step
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Post-traitement

e

On peut exporter les données ou voir le détail en allant dans 'onglet «Graph Management»,
puis en cliquant sur «Show table».

Show table

LGl L
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% 1BER x64 Project: projet ) =8 =
Fies View Utiities Docuts Viewresults Options Window lber Tooks Help

Cewa| 2240 | B8 |IDSIE@IE? ¥ Joer =
P o i@

e,

&
-

B PSh

LAY
be ; DY
- S
w o
e 7%
q 27 _5 L e O
=N -lelxle)

@.u 3 ...'--_; Plot graph | Create | Graph Set Options  Graph
N @ 3 Graphs:
= i Integral of ‘Specific_Discharge_(m2/s) over CutWire1D =
;- ” ntegral of ‘Specific_Discharge_(m2/s)' over ‘CutWire [j
S Options:
"i 91 [¥] Visible
=4 Style: DotLine
i - Celor: =#i0000
[ 7] Color as contour fill

I 10

IA

==

Line width: B D
Pattern: —
Pattern factor: 1

Point size&: =

[Result‘Specific_Discharge_(m2/s)' defined on gauss points will be smocthed to the nodes to get the graph values.
fnl:g ate a vector result: Select a mesh where the result should be integrated. s

e o= 2=
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Post-traitement

e

On peut examiner une multitude de données qui servent a renseigner sur le danger.

menus pour
la forme etN
type de

traitement

icobne pour les
styles de rendu des
calques

e ARSI mlé" |
[ B 55 O Ml [m

temps du calcul

b ] BER x64
Files View Utilities Docuts View results Options Window Iber_Tools Help
CPwe | RRRb0|dE ISR E® | & 2 14
£ e E’%\
Pl o 4

i?;@ L.
0‘\L ';‘
b ST

\\*\‘ Speciﬂc Discharge (m2/s)
X Velocity (m/s)

Xy @ Vx

4

K @ Vy

AR Y IR

IVelocity (mis)]
9.7137
8.6344

l 7.5551
6.4758
5.3965
4.3172
3.2379
2.1586
1.0793
0

= Hydraulic, step 400
22 Smooth Contour Fill ( Mean) of Velocity (m/s), |Velocity (m/s)]|.

Selected new analysis and step. “ x=9.1554e+05

Smooth Contour Fill (M lue) ‘[Velocit /s)|'s Min = 0, Max = 9.7137 E|
mooth Contour Fill ( Mean value) ‘[Velocity_{(m/s)[': Min ax = Jesas00
Command: ' 4 z=0

P D
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Zoom: 1.0x Nodes: 127503, 253440 Render: Smooth (9.1554e+005 54500 ,0) Post
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