B™ Introduction aiber
Christophe Ancey

ber

X

ENACIL.HE|| 2017 1



Plan de la séance

e

* Introduction a Iber : architecture, principes, interface
exemple 1 : écoulement sur un plan incliné
definir la géomeétrie d’ecoulement (directement dans iber)
entrer les donnees générales du probleme
assigner les conditions initiales
Introduire les conditions aux limites
assigner une rugosite
créer le maillage : maillage structure et déstructuré
lancer le calcul
analyse les résultats

O N E W

o exemple 2 : étude de la Navisence a Zinal
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|ber ?

o e
Iber est un modele numeérique bidimensionnel pour la simulation d’écoulements d’eau
(a surface libre) et de processus de transport dans les rivieres et les estuaires. Il est
principalement fondé sur les équations de Saint Venant. Il a été développé en Espagne
par le Groupe Ingénierie de I'Eau et de I' Environnement, GEAMA (Université de La
Corogne) et I'Institut FLUMEN (Université Polytechnique de Catalogne), et le Centre
International des methodes numériques en ingénierie (CIMNE). Le modele Iber fut
Initialement pensé comme une réponse aux besoins du Centre d'études
hydrographiques (CEDEX) qui souhait disposer d’un outil numeérique pour les études
hydrauligues réglementaires en Espagne.

Le modele Iber peut étre télechargé gratuitement a partir de ce site http://iberaula.es
Le site fournit des cours en ligne (payants, en espagnol) et un forum. Le site est en
espagnol, avec des parties en anglais. Le logiciel est en espagnol/anglais (au choix).

L’avantage d’lber par rapport a d’autres solutions est triple : (i) puissant outil d’import
et de maillage, (ii) algorithmes de traitement performants et correspondant aux
techniques les plus avancees, (iii) un outil tout-en-un qui permet d’aller du pré-
traitement au post-traitement.
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|ber ?

o e
Outre un code bidimensionnel de résolution numérique des equations de Saint-Venant,
Iber possede des modules supplémentaires :
 turbulence moyennée (adaptation de modeles empiriques de Manning-Strickler,
parabolique, et longueur de mélange, k-¢)

 transport de sédiment (charriage et suspension) avec prise en compte de formules
empiriques (Meyer-Peter et Miiller, van Rijn, Egelung et Fredsoe) et suspension
(vam Rijn, Smith et McLean, Ariathurai)

Iber peut résoudre les types de problemes suivants :

* hydrodynamique des cours d’eau, canaux, et amenagements hydrauliques (prise
en compte d’ouvrages tels que vannes, ponceaux, seuils). Attention Iber ne sait pas
calculer des mises en charge locale : c’est un code a surface libre !

 rupture de barrage, avec formation de breche et propagation de crue

e ¢tude du transport de sediment

e ¢tude de la qualité des eaux

e zOnages réglementaires

» problemes de ruissellement et d’inondation, drainage, infiltration

« calcul de vagues dues au vent
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|ber ?

e

Iber est un code aux volumes finis avec des maillages fixes structurés ou déstructurés
composes de triangles ou quadrangles. Il résout les équations de Saint-Venant (et
d’Exner) dans un référentiel cartésien a I'aide d’un solveur de Roe (ordre 1 et 2 en
espace, explicite en temps). Il est capable de déetecter les chocs, les interfaces
sec/mouillé, et les changements de regime super- et sub-critique.

Les géometries peuvent étre créées au sein d’lber ou bien étre importées (avec une
grande variété de formats).

La méthode aux volumes finis employée par Iber est écrite dans I'article : Cea, L., and
E. Bladé, A simple and efficient unstructured finite volume scheme for solving the
shallow water equations in overland flow applications, Water Resources Research, 51,
5464-5486, 2015. Voir également la documentation technique du logiciel.
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Architecture d’'Iber

e

Comme pour tous les codes de calcul numériques modernes, I'utilisation d’lber se fait

classiguement en suivant trois étapes :

1. Prétraitement («preprocess») :

e  On définit ou on importe la géométrie a étudier.

* Onpreécise le type de probleme (hydrodynamique, transport de sédiment), la durée
du calcul, les temps auxquels il faut conserver les résultats numériques, et les
parametres de calcul (CFL, type de solveur, etc.).

* Onassigne les conditions initiales, les conditions aux limites, et la rugosité locale.

e Ongénere un maillage a partir de la géometrie

2. Calcul : le calcul est réalisé par un exécutable qui tient compte des parametres
entres.

3. Post-traitement («postprocess») : on peut représenter les variations spatiales et
temporelles des variables d’intérét (vitesse, Froude, hauteur, etc.), créer des
animations videos, exporter les données et graphes au format souhaite, ou
réaliser des analyses assistées par ordinateur (p.ex. cartographie du danger).
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Presentation de lI'interface en prétraitement

e

IBER x64 Project: UNNAMED (BER) P |= @] =
Fies View Geometry Utlities Data Mesh Calculate Tber Tools Help
CoRRRNd BB D e -S| 2?79 Sber Emmes

D) BB B

I8 BT
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1—. x
Some changes on preferency een discarte:
\Accepted new preferences
mmmmmmm : &+
Zumi 10x Nodos: 0, Elementos: 0 Tluminacign: Normal (91759 ,0.065327 ,0)
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Présentation de lI'interface

e

o a_ . .

rossir la vue (zoom in
| Ve’ g ( )
B dégrossir (zoom out)
a

— voir tout le projet

rafraichir la vue

voir en rotation
se déplacer dans la vue (Shift + clic droit)

créer des lignes

créer des surfaces NURBS
(non-uniform rational B-spline)

effacer
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Présentation de lI'interface

e

Uinterface est personnalisable depuis Utilities > Preferencies

S ' ey v - ~ - — oo
4 IBER x64 Project: UNNAMED (IBER) . » — - ' P p— A
Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help
[N =1 . ——
CEBERP B PDD e -S| 22 ¥ Yber Toonz
2 e
&£
-F
A
L e
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A&
— <€
\ b Preferences Window @
=7
[ General Messages
‘h\ ‘ﬂ Interface Language: English ¥
L%\é i m?!ef Interface options
‘-: * B Gra:hlcal ] Splash window
() ppearance : . ” pe
ey Cohoars Help display style: Pop-up tooltip when stop over
';7} System Toolbars: 0 -
2 £ Meshing Create new point: Never =
"‘ ['Z, Main [¥] Display coordinates
: Other Automatic redraw: All windows ¥
-« %‘;{ Boundary Layer Popup messages: Normal -
@ .%. Cartesian mesher 7] Play sound
' 4 Sphere mesher Y
— % Tmport and Bxpoet [] Shrink windows when selecting
<\,0 w Fonts Num of recent files: 5
Grid [7] Embedded progress bar
@ Postprocess
o
Fes
a
$ Default Values
& Y -
I ha t Apply
XY x
t.
[Some changes on preferences has been discarted * x=7.3957
’ d ef 2]
Accepted new preferences \: y=-4.8903
Command: | &+ =0
Zum: 1.0x Nodos: 0, 0 lluminacién: Normal (7.3957 ,-4.8993 0) Pre
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Présentation de lI'interface

e

Par exemple depuis Utilities > preferencies > Grid, on peut afficher une grille

% IBERx64 Project: UNNAMED (IBER) » P = =8 %
Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help
Coa|BRRd B PE v -S|l22 |9 ber Tovs
2 o
»\2
8=
a 3
L
0 '
|~ E
< a: Preferences Window @
= G} General General | options
—\ TI Interface [7] Show axis
C Other [¥] Show grid lines
52 1 £} Graphical A
i Show labels
S ’ Appearance [l Activati
- Colours = fvate snap
.{‘: Zi System Center
g r?‘ E} Meshing X Center: 0
Nl‘ {2‘ Main Y Center: 0
= Other Extents
é?" ?{ Boundary Layer X Extents: 15
@ .% Cartesian mesher ¥ Extents: 10
4 Sphere mesher Soacht
o '% Import and Export X P _g
o & + Fonts Spacing:1
Grid Y Spacing: 1
@ - Postprocess Major line every: 5
K
a
@ Default Values
| ] »
& ¥
A =
XY x
.
Ejﬂccept?d new preferences =
\Accepted new preferences :%\ y=-4.9856
Comman d: &+ =0
Zum: 1.0x Nodos: 0, Elementos: 0 lluminacién: Normal (3.8417 ,-4.9856 ,0) Pre
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Creation de la géométrie

On va créer un canal incliné de 1 %, long de 100 m, et large de 5 m

<l
&
e
2,
2
=N On va se servir de l'outil «create line»

% (accessible aussi depuis Geometry > Create > Straight line
B

p

&

&

i

th

?

A )

Zum: 1.0x Nodos: 0, Elementos: 0 Tluminacién: Normal (034532 ,-4.4245 0) Pre
e ———————— e e ee— e = o= o= s ——

.
0N 2

Files View Geometry Utilities Data Mesh Calculate Iber Tools Help
OO WERD | BA|IP e -8 %29
® ®
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Creation de la géométrie

Dans la fenétre du bas, on tape les coordonnées 0,0,0 du coin aval gauche du canal, puis
on appuie sur la touche «Enter»

'Y BERx64 Project: UNNAMED (IBER) " = |3
Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help
COO|BRRD | BE|PDE Ly -S| 22 HA oo e

o e

;4

DYANY-I-%
L@p®

A [

On inscrit les coordonnées cartésiennes

!

2128 BAITD

CHEOSOHEBIPPARR LS

y

;Ent’a points to define line (§5C to leave) A 4—-83453
->0,00 ¢ =
< y=-423%4
Comman d | ®/ + =0
Zum: 1.0x Nodos: 0, Elementos: 0 lluminacién: Normal (-8.3453 ,-4.2374 ,0) Pre
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Creation de la geométrie

On inscrit les coordonnées du point amont gauche, et comme la pente est de 1 %, il
est situé a la cote relative 0,01 X 100 =1 m. On inscrit donc 100,0,1 comme
coordonnées. Une fois que cela est fait, on appuie sur la touche «Enter», puis «ESC»
pour terminer la saisie.

§ R o UNNAMED 0860 - - . L el
COBILERT BRI bo - S|4 o

52

Q2

‘s

g On inscrit les coordonnées cartésiennes du coin amont gauche
2 |

LA

y

1—} o
Enter points to define line (ESQto leave) * x=-83453
->0,0,0 C sy

2=0

Comman d: 1100,0.1] B =
Zum: 1.0x Nodos: 0, Elementos: 0 Tluminacién: Normal (-83453,-4.2374.0) Pre

CHEOHRBYBPY RSP LS
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Creation de la géométrie

La ligne s’affiche. Cliquez sur 'outil «Zoom frame» pour voir 'objet. Comme la grille
est trop petite, on peut revoir ses parametres dans Utilities > Preferences > Grid

Preferences Window

3
=

& General
Interface
Other
C} Graphical
Appearance
Colours
System
CF Meshing
Main
Other
Boundary Layer
Cartesian mesher
Sphere mesher
Import and Export
- Fonts
Grid
Postprocess

General options
"] Show axis

V| Show grid lines
| Show labels

"] Activate snap
Center

X Center: 0

Y Center: 0
Extents

Xbxents: 100 e

Y Extents: 20|
Spacing

X Spacing: 1

Y Spacing: 1
Major line every:

Default Values

£

\

| Apply | | Close |

— On modifie les valeurs
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Creation de la géométrie

On peut procéder de la méme fagcon pour générer les autres lignes qui forment le
canal. On va ici procéder différemment avec l'outil «Copy» du menu

& IBERx64 Project: UNNAMED (IBER) el [

Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help

COR|RRRP BRI QPD Ly 2|22 |49 Voor T

o e
o[£
| —
a a Copy [=]
5 T 2]
0 L Entities type:  Points A

E
‘}' = Transformation: Translation ~
.\_ g First point
NI Num: x 0.0

B ﬁ y: 0.0
St [o]=00

:'. .-‘ # Second point

?z e <

A‘ - z 00 M H
_j.,“ On fait une translation

%
-

@
4RI

|
EF I ER RS

~ de y=+5

| Duplicate entities

Do extrude: Surfac“

FE Create contacts

'f,fll [¥] Maintain layers Au p a Ssa gel O n e n

éf' ultiple copies: H A -

A | profite pour créer |a

<4

& - surface

®
Leaving line creation. 0 new lines £ x=29.162
IAccepted new preferences z y=-49.391
Command: | | + =0

Zum:1.0x Nodos: 0, Elementos: 0 Iluminacion: Normal (29.162 ,-49.391 ,0) Pre
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Creation de la geométrie

On peut procéder de la méme fagcon pour générer les autres lignes qui forment le
canal. On va ici procéder différemment avec l'outil «Copy» du menu

i % IBER x64 Project: UNNAMED (IBER)
!kﬁle: View Geometry Utilities Data Mesh Calculate Iber_Tools Help
T ] - J s
0 {195} 6 | ,;f;;‘%Vl ﬁ . | \‘\ m Layerd
¥ 9
@3
& —
a @ Co [=]
5 e Py 2|

S IBAITS
BEP P09 Ad

]

e
#

€ EQH o

Command:

Transformation:  Translation ~

First point
Num: x 0.0
y: 00

l]z 00

Second point
Num: x 0.0
y: 5

Bl

Duplicate entities
Do etrude: Surfaces ~

Create contacts

Entities type:  Lines &
.y

-S|l 22 |¥

-« A==
ber vsoon 2

\ On choisit 'option

«Lines»

En appuyant sur
«Select», le pointeur de

[¥] Maintain layers
Multiple copies: 1
y — =
L Select | Cancel
x

Enter Points to Copy
No entities selected. No changes

Zum: 1.0x

B T
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Creation de la geométrie

On peut procéder de la méme fagcon pour générer les autres lignes qui forment le
canal. On va ici procéder difféeremment avec l'outil «Copy» du menu

3 IBER x64 Project: UNNAMED (IBER) o B X

iFi\es View Geometry Utilities Data Mesh Calculate Iber Tools Help

OCOBIVIEREIBE| QD e -slez?|4 Voo

‘o @ Le cadre bleu représente
o0 le canal

Qaloas et/

| B A
=%

24|

2 |

Le cadre fuchsia est
indicatif (il indique que
la surface est close,

],_, préte au maillage)
Enter 1st point > x=20.805
Enter 2nd point 3 105
| Command: &+ =0

Zum: 1.0x Nodos: 0, Elementos: 0 lluminacién: Normal (20.805,-19.589,0) Pre
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Parametres du calcul

On va étudier un probléme ou on lache un flux d’eau a débit constant Q = 500 I/s.
On fixe la durée de la simulation a 2 min (120 s). Pour cela on va dans la menu Data
> Problem data... Une fenétre s’ouvre : on entre les données. On sauvegarde les

données toutes les 10 s.

Data

(5]

Simulation New v
Initial time [s] 0
Max simulation time [s] 120 (—

1| TimeParameters | General | Results | Custom Hazard | Turbulence | Sediments | Encroachment | Breach | Water Quality !I

Results time interval [s] 10

Time Options Not Sho

v

— durée de la simulation

| Accept | [ Close |

@

intervalle de
temps entre deux
sauvegardes des
résultats

Lt
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Parametres du calcul

Dans le second onglet, on trouve des renseignements sur le solveur : nombre de

processus, ordre du schéma, condition de Courant Friedrichs Lewy (stabilité du

schéma), limite sec/mouillé. On peut aussi définir la rugosité des parois et d’autres
parametres. On ne touche rien pour I'instant, on y reviendra dans un second temps.

Data

B

Analysis 2D
Number of Threads 1
Numerical Scheme First Order|[Fastest] v
CFL 045 —

—_—

Wet-Dry limit [m] 0.01
Drying Method Default

General Options Show
Strict Courant Condition OFF ~

Friction on walls Manning Coefficient

Wall Roughness 0.001
Molecular viscosity [m2/s] 0.000001
| Baroclinic Pressure
| Coriolis
| Fill Sinks

| Simulation Details

| Accept | [ Close |

Time Parameters  General | Results | Custom Hazard | Turbulence | Sediments | Encroachment | Breach | Water Quality H

K| @

CFL (elle ne doit jamais
étre >1)

limite sec/mouillé

Lt
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Parametres du calcul

Dans le menu Data > Hydrodynamics > Boundary conditions, on peut fixer les
conditions aux limites (CL) amont et aval. On suppose le régime subcritique a

I'amont.
2D Analysis (=]
2D Inlet v € 2| @

S 4

Inlet Total Discharge

Inlet Condition Critical/Subcritical

Total Discharge| Time[s] || Q [m3/s] @

Inlet Num 1

v

CL amont

\ type de CL

—

valeur de Q

___—pour assigner sur quelle

-

frontiere la CL s’applique

Draw

Assign e]ms Unassign

Close

Lt
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Parametres du calcul

On entre le débit Q = 0,5 m/s, puis on clique sur Assign. Le pointeur de la souris
change de forme et permet d’assigner la CL a une frontiere donnée.

2D Analysis B
2D Inlet - )
Inlet Total Discharge v
Inlet Condition Critical/Subcritical v
Total Discharge ___Time [s] | Qm3/s]
0.0 0.5
Inlet Num
& &
N
valeur de Q
pour assigner sur quelle
i frontiere la CL s’applique
| [ Assign Entities Draw Unassign
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Parametres du calcul

On entre le débit Q = 0,5 m/s, puis on clique sur «Assign». Le pointeur de la souris
change de forme et permet d’assigner la CL a une frontiere donnée.

% IBER x64 Project: projet1 (IBER)

Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help

(o ~K-JRENER AN - F

» e

2D Analysis

2D Inlet

Inlet Total Discharge
Inlet Condition Critical/Subcritical
Total Discharge| Time[s] || (

Inlet Num|1

(m3/s] [ £

w2 &

Enter Lines with new values

Added 1 new lines to the selection. Enter more lines. (ESC to leave)

Command:

Zoom: 1.0x

Nodes: 0, Elements: 0

Render: Normal

cliquez sur «Finish»
pour finir

frontiere ou la CL
sur Q s‘appligue

~ x=71011
< y=13796
i + z=0

Pre

Lt
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Parametres du calcul

On fait de méme pour les conditions aux limites a I'aval en choisissant «2D outlet»
dans le menu déroulant. On assigne la frontiere a gauche, puis on clique sur
«Finish» et enfin «Close»

3 IBER %64 Project: projetl (IBER) W P T W T——_——" =8 %
Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help

OO LR EP | BR|PE Ly -S|l®249 o T
P e

= 2D Analysis B

on choisir «critical»

20 Outlet 2|
\. ef 2
\Hﬁ'a-s} SUPERCRITICAL/CRITICAL ~

Outlet Num|1

AOWNARY.- 1)

| ) [
BEBPErP L9 AAN @RI ® |

: |

A

& |

T~

| Finish. | Press ‘Finish' to Na Unassign |

Close \

—~—

7

frontiere ou la CL
L sur Q s’applique

BT S

Enter Lines with new values * x=99177
Added 1 new lines to the selection, Enter more lines. (ESC to leave)

Command: B =0

Zoom: 1.0x Nodes: 0, Elements: 0 Render: Normal (99.177 ,-48.861 ,0) Pre
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Parametres du calcul

Dans le menu Data > Roughness > Land use, on peut choisir la rugosité. Dans le
menu déroulant, on choisit «concrete». Iber donne la valeur par défaut n = 0,018.
Cela donne K = 55 m/3/s. On a du béton rugueux et on prendre K = 50 m/3/s, soit
n=0,02. On change la valeur et on la sauvegarde. On assigne ensuite la surface avec
«Assign>Surfaces», on clique sur la surface NURBS, puis «ESC» pour sortir.

% IBER x64 Project: projetl (IBER) = 8 =
[Files View Geometry Utiities Data Mesh Colculste Iber_Tools Help

‘O@@‘ﬁﬂ-,%’lﬂglqoﬂ Layedd - @I@?iﬂ N
o e

&3

9 Land Use . ] h I I

2 oot on change la valeur,
b Manning 0.025

puis la sauvegarde

BONMTOSeNEBSB Y%A L9 AAN R I ® K

L4 |BA| D)

‘Assign sign | Exchange |

assigner la
surface

<

r

Saved
WAssigned 1 new Lines to condition: 2D_Outlet

Command: [
| Zoom: 1.0x Nodes: 0, Elements: 0 Render: Normal (35917 ,-47.807 ,0) Pre
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Maillage

On en a fini avec les parametres. On va mailler maintenant le domaine avec des
mailles non structurées (triangles) de taille 1 m. On va sur Mesh > Unstructured >
Assign sizes on surfaces. Une fenétre apparait. On choisit 1 m, puis on assigne la
surface NURBS associée et on termine avec «ESC», puis «Close».

Y IBER x64 Project: projet1 (IBER) =8 %

metry Utilities Data Mesh Calculate Iber_Tools Help

é&:‘élié ‘J‘c;\ﬁ:-.,%' # | \Q‘QG Layerd > %l @ ? ‘ﬂ t’-ht*wj
£ e

;o g . .

taille de la maille

enm

Enter value window / E\

9 Enter size to assigefto surfaces
(0.0 to unassj

00
e Assig* Close_| ‘7‘47—‘""" gaa: I
l =

128 840D

BONFTOSAHRBE RIS RL9IAAN @RI @ |

assigner la
L surface

Zoom: 1.0x Nodes: 0, Elements: 0 Render: Normal (-24.632 56.873 ,0) Pre
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Maillage

Dans le menu Mesh > Generate mesh, on peut générer le maillage. On est
maintenant prét pour le calcul. On n‘oublie pas de sauver !

on peut laisser tel

q ue I Progress in meshing (]
Mesh generated.
Num. of Triangle elements=1128
Q) Num. of nodes=670

Mesh generation / ‘E\

Enter size of elem o be generated

Num nodes Meshing evolution
Memory KB
5 > 1000001
90000
80000 A
70000 -
{ oK ] { Cancel } 600001
50000
400001
300004
200004
10000+

["] Get meshing parameters from model

Time (seconds)

[Vimr@[ Close |

\ permet de

visualiser le
maillage
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Maillage

On obtient le maillage suivant :

78

WAYATAYAY
TAVAVATAVA

7 \

HHHHA i)

AV

A
FAVAYAVAIZAY
VATAVAVA

A
v ATV

WAVAVAVAY'
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Post-traitement

{
[
|
|
i

| |Velocity (m/s)|

|

|

\

|

|

l

? —t - 1.0805
} l 1.067
‘ )

|

|

|

1.0535
- 1.04

1.0265

1.013

' | | | | | ‘ 0.9995
g | | I | i 1 - - : : : ' ' ‘ - o 0.98601

0.97251
< 0.95901

Hydraulic, step 120 2
Smooth Contour Fill ( Mean) of Velocity (m/s), |Velocity (nm/s)|. Yber
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Calcul

Dans le menu Calculate, on choisit «Calculate». Si le calcul est long, on peut
regarder ce qui se passer en cliquant sur Calculate > View process info... Une fois le
calcul fini, une fenétre s’affiche et on choisit «Postprocess».

% IBER x64 Project: projet1 (IBER) . S o — o | = E XS

Files View Geometry Utilities Dotz Mesh (Calculate ' Iber Tools Help

$lBE| QDD e -S| 229 i
fenétre d’information

9))
>

outp\info for ‘current’ Sat May 13 15:49:27 ]

.050 0.11920 15:49:33:15 0.500

«107
065 | Processinfo ="

} |..

M =
| .023
4 i1 A Process 'projet1’ started at Sat
20| 55 May 13 15:49:27 has finished.

.025
.088
.063

Postprocess

.027

2128 &
g~y L9AAL

1s:

-11868

DO0O00DODO0O00O00O0000

.083 0 0
.0s8 0.11817  15:49:33:72 0.
.002 0.11901  15:49:33:77 0.
o .056 0.11900  15:49:33:82 0.
Fis .118 0.11862 15:49:33:87 0.
:ﬂ 084 0.11814 15:49:33:91 0.
- .050 0.11792 15:49:33:26 0.
¥R .010 0.11796  15:49:34:01 0.
1200.086 0.11847  15:49:34:06 0.
& COMPUTATION FINISHED SUCCESSFULLY!
B& Y 13:05:2017
tf" 15:49:34
? 1—» - L I+ =N

o Close \ pour passer au
P e post-traitement

Process 'projetl’ started at Sat May 13 15:49:27 has finished.

Command:

Zoom: 1.0x Nodes: 670, Elements: 1128 Render: Normal (34.601 ,0.79024 ,0) Pre |

|l | Eemplel ENACILHE | 2017
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Post-traitement

Pour afficher les résultats, on clique sur I'icone «Results window» et on choisit le
type de représentation que l'on veut. Par exemple, une carte des vitesses au temps
120 s. Il faut parfois jouer avec I'icone «Display style» pour afficher les cartes.

3 IBERx64 Project: projetl e = | B PX4
Files View Utilities Docuts Viewresults Options Window Iber Tools Help
Cewal s :.::-.:‘"I" & Yber Toonnz

PO LN

fenétre de

|

12 N2

°
5
BN fodill F—— 4 I
e 4 View Results & Deformation =] resu tats
i 4: View results | Main Mesh | Reference mesh | I
[5]. 34 - : |
== Q View: Smooth ContourFill  + Step: |- = =
p{‘ | Analysis: Hydraulic - 1200 ~ £
— @ Depth (m)
lm ﬁ Froude
'; @ Specific Discharge (m2/s)
l:g @ Velocity (m/s)
" @ Vx
W o Vy
2N 9. |Velocity (m/s)|
o, Bl Velocity (m/s)] 1.0805
@ Water Elevation (m) I 1'057
1.0535
-1.04
-1.0265
i 1013
- 0.9995
A Close
Fyeed
0.97251

| x 0.95901

Hydraulic, step 120
Smooth Contour Fill ( Mean) of Velocity (m/s), |Velocity (mvs)|.

Postprocess ready. * x=-25.959

Smooth Contour Fill ( Mean value) ‘[Velocity_(m/s)|": Min = 0.95901, Max = 1.0805 = v=-45.256

Command: &+ =0
Zoom: 1.0x Nodes: 670, Elements: 1128 Render: Smooth (-25.959 ,-45.256 ,0) Post
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ECOLE POLYTECHNIQUE
FEDERALE DE LAUSANNE




Post-traitement

On peut afficher les temps a différents pas de temps

% IBER x64 Project: projetl

- =anc)

Files View Utilities Do cuts View resy View Results & Deformation

View results |MainMesh Reference mesh |

View: Smooth Contour Fill ~
Analysis: Hydraulic A
[ Ll Depth (m)

@ Froude
B Specific Discharge (m2/s)
@ Velocity (m/s)

@ Water Elevation (m)

Yber i

on est au
tempst=60s

Depth (m)

4> ' 0.099821

0.09038

Leaving draw vectors.
Smooth Contour Fill ( Mean value) 'Depth_(m)": Min = 0.014856, Max = 0.099821

, la hauteur est proche du
. seuil sec/mouillé

¥ 0.08094
0.071499
. 0.062050
I 0052618
- 0.043178
0.033737
0.024207

0.014856

Hydraulic, step 60
Smooth Contour Fill ( Mean) of Depth (m).

Command: |

Zoom: 1.0x Nodes: 670, Elements: 1128

Render: Smooth (45.591 ,-26.313,0)

- Ql ] Exemplel 2
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Post-traitement

On peut chercher des valeurs particulieres en allant sur View > Label > Select > Res

% IBER w64 Project: projet]

Files [Wiew | Utliies Docuts Viewresulls Opbons Window  lbes_Tools Help

OQ Zoam : :‘—"‘|<‘\\Qﬁ‘§3§iﬁ|@?|'ﬂ

Perspective...

0 1| Cupplanes.
i

Advanced viewing settings...

— ] ebe
W, View
1 Recent view files
Background image
& <
£l Image to clipbeard
¥ Multiphe windows..

»®
‘* Mode
s _;E +f+ Full sereen

23S
A, cf?:‘
= &

21
17
<7
-3

v

II‘

:

4

w -

il suffit alors de cliquer ou
I’'on veut (ESC pour finir)

3

l—b =
Hydraulic, stap 60
Smooth Contour Fill { Mean)

Lt
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FEDERALE DE LAUSANNE

choix de l'outil
«data point»

Pour effacer les points, aller
dans View > Label > Off
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Post-traitement

On peut tracer des profils de hauteur. On va dans Do cuts > 2D Polygonal Cut, puis
on sélectionne les points, on finit avec «ESC». On clique ensuite sur 'icone «draw

instantaneous water profile»

% IBER x64 Project: projetl

Files View Utilities [Docuts] View results Options Window Tools Help

O P D | 4 Cutplane 'S e

@ e Divide by selection

& ___.; [:.‘-" \-' Divide surface sets L

LW ¢ by = Divide lines v

8 — 2D Polygonal Cu

'.m. @ T;E“u Convert cuts to sul ets . ) . .

E' : :\ Automatically convert cut Taget Ouvrlr I Outll ((VIeW
L

graphs»

2%

10 %
[|BES @M N

B IONDIO B4 &

outil pour profil
de hauteur

|:“\\ |‘ﬁ7'¢ IS

choix de l'outil

& == -
I i

AT

(5

Gl | Bemplel 2 ENACILHE | 2017
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Post-traitement

On obtient un profil de la hauteur d’eau et du canal :

Graphs Window

graphset-2

112

0.96

0.8

0.64

0.48

0.32

0.16

-

w&aph Manag&
1 1 1

Plot graph ‘ Create | Graph Set
Elevation_(m)

1

option du
dessin

gestion des graphes

graphset-2
—=— Cut 1 boundary graph ( 2). Step 0

—*= Cut 1 boundary graph ( 3). Step 60

44 55

66

77

T T

1
88 99 110
Line Variation

Lt
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Post-traitement

On peut tracer d’autres profils dans 'onglet «Create» de la fenétre

Graphs Window (=]
graphset-2 A
Plot graph  Create \ Graph Set Options | Graph Management
From result
View: Line Graph v Analysis: Maps_of_Maximums v Step: 1200 v
X axis: Y axis:

o 7 Variation 2 Velocity (m/s)
o Water Elevation (m)

@ X Variation @ Depth (m)
@ Y Variation @ Specific Discharg

outil pour coupe création d’un nouveau graphique

de la hauteur création de la ligne de
ST / e

Apply Close

(gl | Eemplel ENACILHE | 2017

ECOLE POLYTECHNIQUE
FEDERALE DE LAUSANNE



Post-traitement

Le probleme est que le précédent graphique est toujours visible. On le supprime en
allant dans l'onglet «Graph Management»

Graphs Window

graphset-2 A

Plot graph ‘ Create | Graph Set Options | Graph Management |
Elevation_(m) .\ l

112 —] I graphset-2
L1 —*— Cut 1 boundary graph ( 2). Step 0
0.96 — —=— Cut 1 boundary graph ( 3). Step 60
—*= Line Graph in LayerO ( 6). Step 120
0.8 — |
0.64 — —
0.48 — l—
0.32 —] , —
aller dans l'onglet «Graph
0.16 — -
1 e ) Management»
0 —| =" nouveau profil a
-0.16 = =
0 1 22 77 88 99 110

Line Variation

Lt
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Post-traitement

On choisit le graphique a supprimer et on exécute la suppression avec I'icone a
droite du menu déroulant.

Graphs Window @

graphset-2 v

Plot graph | Create | Graph Set Options Graph Management |

Graphs:

Cuti boundary graph ( 2). Step 0 - E]

Options:
[¥] Visible

Style: DotLine -

Color: #§0000 =
[T] Color as contour fill

Line width: B EIO

Pattern: = |----e-- i

Pattern factor: 1

Point size: E] ﬁo

Values: [ Show table ]

| Apply | [ Close |

ICP AU ENACILHE | 2017 38
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Post-traitement

On va affiner les calculs en revenant a I'étape du calcul. Pour cela, on va cliquer sur
I'icone «Toggle between pre and postprocess». On peut prendre une photo avant
cela pour faire la comparaison (cliguer sur I'icone «Take a snaphot»).

% IBER x64 Project: projetl a Been & == 25

Files View Utilities Docuts Viewresults Options Window Iber_Tools Help

Cowe | WRRdO ﬁﬂﬁ\@%s\aom@?l-ﬂ Yber T
P o i@

P

L

&

© 2. faire une photo bascule vers le mode «preprocess» (calcul)

FEQS

- (export)

B QP [n i @ |

PIgNDHL 3L |5

ERnNIREEEIAE

|Froude|

1.168
1.1446
I1.1212
1.0978
£ 1.0743
1.0509

1.0275
y ! 1 1 | | 1 I 110041

2

0.9807
0.9573

Hydraulic, step 120
Smooth Contour Fill ( Mean) of Froude, |Froude|.

ﬁrjaph ‘Cutl l;nundnry graph ( 73]."’3(;;;60‘ deleted, |
'Smooth Contour Fill ( Mean value) ‘[Froude|': Min = 09573, Max = 1.168

x=99.540
y=-2623

4 [ »

4

Command: ﬁ
Zoom: 1.0x Nodes: 670, Elements: 1128 Render: Smooth (99.549 ,-26.23 ,0) Post
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Calcul affiné

Dans le menu Data > Problem Data, modifiez les paramétres comme suit :

Data

Analysis 2D
Number of Threads 1

Numerical Scheme 2nd Order
CFL 045
Wet-Dry limit [m] 0.00t
Drying Method Defau ¥

General Options Show v
Strict Courant Condition OFF

Friction on walls Manning Coefficient

Wall Manning 0.015
Molecular viscosity [m2/s] 0.000001
(] Baroclinic Pressure
(] Coriolis
("] Fill Sinks

("] Simulation Details

Time Parameters  General | Results \ Custom Hazard \Turbulence \ Sediments |Encroachment \ Breach \WaterQuality IH

prendre 0.001

v

@

prendre «2" order»

Accept ] [ Close ]

Lt
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Calcul affiné

On va aussi remailler avec une maille plus fine de 50 cm

%) IBER x64

Project: projet1 (IBER)

Files View Geometry Utilities Data [Mesh| Calculate Iber_Tools Help

CeoleBRd

o e

HEBOHFOSORE

Unstructured
Structured
Cartesian

o Assign sizes on points
2 . Assign sizes on lines
» |~ Assign siz aces

Boundary layer

(¥ Sizes by chordal error...

Quadratic type
Element type
Mesh criteria
Reset mesh data

Draw

N Sizes by background mesh...

> Correct sizes...

\

4 Assign entities

3

s

% Generate mesh...

Erase mesh
Edit mesh

Show errors...

Ctrl-g

Y\

View mesh boundary

Create boundary mesh

Mesh quality...

Mesh options from model

' prendre une maille
de 50 cm

générez de nouveau

Lt
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Calcul affiné

On obtient un nouveau maillage :

s b RO RN e A D O BB el

SIZIAANAS

i)

T30 8 40 0 8 O N S 1 A A 0 B R N D DR

Lt
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A AR AV TNV P O
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Post-traitement

On note les changements dans |'allure et les valeurs calculées. On peut faire une
photo pour comparer avec le cas précédent.

4 IBERx64 PRl oo i PR pp—— ‘ e = 8 (= [ B
Files View Utilities Docuts Viewresd View Results & Deformation - (s]}
O @ Q| L2 G255 (| Viewresuts | MainMesh | Reference mesh | &1 Yber oo
ﬁ [ ] Q% \?::' View: Smooth Contour Fill  + Step:
PHERT Analysis: Hydraulic - 1200 ~
call —— @ Depth (m)
‘P '["E‘- Froude
ﬁg "- @ Froudex
| - 9 Froudey
9 EQ ¥
= P e .
/ E Q % T 3|;'eci!ic ?yz;f;drge(ndls)
— 3 ocity (m/s)
W & \X\‘ @ Water Elevation (m)
X
xy wX b
= 3 [ f )50,
ORI >
Ky 47 Ny
D 5§ Avply
N in @
Pyl | ' - - L
M4 A
PR
4 = FEN_ R N N PN NN il ==
21 &
17
7
9
"
il
®‘ | |Froude|
4 1 i i T 1 0 I I 1.1257
1.1022
1.0788
- 1.0553
1.0318
1.0083
0.98482
N 0.96134
0.93786
x 0.91437
Hydraulic, step 120
Smooth Contour Fill ( Mean) of Froude, |[Froude|.
[Smooth Contour Fill ( Mean value) ‘Froude_x": Min = -1.1257, Max = -0.91437 £ x=45591
!Smuoth Contour Fill { Mean value) '|Froude|': Min = 0.91437, Max = 1.1257 E
| < y=-239%
Command: | B+ z=0
[ Zoom: 1.0x Nodes: 2379, Elements: 4336 Render: Smooth (45.591 ,-23.999 ,0) Post
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Post-traitement

En allant dans Windows > Animate, on peut voir défiler les simulations aux temps

sélectionnés.

7 IBERx64

Project: ptpjﬂl
iew  Utilities Do cuts ~ View
bowel|
I SN
@S
5=

ults Option

+0|BE F0S

Window

)
elp

e

S| & ?

-
Tanimate

@

Im

4 Options
7] Results View
Automatic Limits
Deformation
Endless

Fromstep|l  |tostep|13

IR wORR

AR Ak b AN

Duration
Set duration by:

Total Time: 5 5.

5
ok

@ Delay between steps: 200 ms.

24 ] Use step values as seconds

21 &
Pl
|z o
Iz Step number: 7
-9
n
1]
s ool
9/elo
Save image
Save PNG on

Save animation
[ Save | AV

reat pic animation

Default ~ | Resize

[7] use step values a5 scaled delays

Step value: 60.0

00:00

7

i

aiC]

Close |

i..

Maximum value reset.

Smooth Contour Fill { Mean value) ‘|Froude|: Min = 0.93318, Max = 2.2805

Command:

|Froude|

22805

I 21308
1.9811

18314

16817
1,532

: 1.3823

12326

1.0829

0.93318

Hydraulic, step 60
Smooth Contour Fill ( Mean) of Froude, |Froude|.

Lt
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Calcul affiné

On va mailler le domaine avec une grille structurée composée de quadrangles de
taille 50 X 10 cm. On bascule en mode prétraitement, puis on va dans Structured>
Lines> Assign size

a | Mesh | Calculate Iber_Tools Help

Unstructured 'L & | 2% 2 | )
Structured “. Lines Assign number of cells
Cartesian L4 “'{j Surfaces * Assign size
Boundary layer » Concentrate elements
Quadratic type 4
Element type L
Mesh criteria L
Reset mesh data
Draw 4
< Generate mesh... Ctrl-g
Erase mesh
Edit mesh L
Show errors..
View mesh boundary
Create boundary mesh
Mesh quality...
Mesh options from model

ICP AU ENACILHE | 2017 45
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Calcul affiné

Une fenétre s’affiche, on tape 0.5 (m), puis on sélectionne les deux lignes
horizontales (les mailles alignées le long de I'axe x auront pour longueur 50 cm).

% IBER x64 Project: projet1 (IBER) o8 =

try Utilities Data Mesh Calculate Iber_Tools Help

Oﬁﬁl{\”iﬁ;‘%[ Al e -S| 2?4 Yber o

-f Enter value window @

o f 0 Enter mesh size to assign to lines
ok _ :

09

= Assign Close
=% [ asion ] [ cose ]

mmmmm & "

Zoom: 1.0x Nodes: 10252, 10000 Render: Normal (42.947 ,32.108 ,0) Pre

l(l’ﬂ- ENACILHE | 2017
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Calcul affiné

On arréte la sélection en appuyant sur «ESC», alors une nouvelle fenétre s’affiche.
On inscrit 0.1 (m). On sélectionne les deux arétes verticales et on tape sur «ESC»,
puis «Close». On finit cette étape en remaillant Mesh > Generate mesh.

% IBER x64 Project: projet1 (IBER) PSS R

Vie Geometry Utilities Data Mesh Calculate Iber_ Tools  Help

Files View
COBWERP BR[O o -&|l®? |49 Yier e

%

) TNOGE

| (5
Sl

BOMTOSGHRIGPRRIARLIAAN R I @ Ko

-<;r|‘ Enter value window @

Al 1 (2) Enter another mesh sizeto ||
- assign to lines

d‘

Q,‘ 0]

<~«. r Assign Close

L.

Added 1 new lines to the selection. Enter more lines. (ESC to leave)

2 x=69191
Assigned 2 number of cells to 2 lines £
~ y=48302
Command: ' 4 =0
Zoom: 1.0x Nodes: 10252, Elements: 10000 Render: Normal (6.9191 ,4.8392 0) Pre
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Calcul affiné

Si on agrandit le maillage, on vérifie gu’on a bien |la forme désirée. On peut alors
relancer le calcul : Calculate > Calculate. Cela prend un peu plus de temps !

3 IBER x64 Project: projetl (IBER) = |8 R
Files View Geometry Utilities Data Mesh Calculate Iber_Tools Help

Y — - ——

+ | BE|RPDL e -S| 224 Yber Toennz

output info for 'current’ Sat May 13 18:23:14

LB BRP R L AR @D @ |

X
5

L

0

5 /)

= 10.

Bl 20.
i 30.

ZN" 40.

— 50.

> &0.

o, 70.

?‘:}‘ 80.

2 s0.

<5 100.

%

a9 IR W W R

Calculating edge connectivities

NUMERICAL SCHEME: Roe 2nd Order

[

A
b
&
A
i
A"

MMM L AL

l—b *
Enter 2nd point

33 files written OK

Command:

Zoom: 1.0x Nodes: 10251, Elements: 10000

Initial volume: 0.00 m3
Simulation time Time step Time Qin Qout
0.000 1.00000 18:23:16:70 0.000 0.000 L
10.002 0.02213 18:23:17:24 0.500 0.000
20.018 0.02223 18:23:18:04 0.500 0.000
30.022 0.02223 18:23:19:09 0.500 0.000
40.015 0.02219 18:23:20:41 0.500 0.000
50.018 0.02217 18:23:21:97 0.500 0.000
2 x=-090361
. y=44846
[~ s z=0
Render: Normal (-0.90361 ,4.4846 ,0) Pre
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Post-traitement

On revient en post-traitement et on trace la carte du nombre de Froude.

% IBER x64 Project: projetl = |8
Files View Utilities Docuts Viewresults Options Window Iber_Tools Help
COwe | BERPO BRSSO E =2 | Yber Tomer

Smooth Contour Fill ( Mean value) '|Froude|': Min = 0.76424, Max = 1.0984
Smooth Contour Fill { Mean value) ‘|Froude|': Min = 0.76424, Max = 1.0984

Hydraulic, step 120
Smooth Contour Fill ( Mean) of Froude, |Froude|.

|Froude|
1.0984
' 1.0613
§ 1.0242
- 0.98703

- 0.9499
Moogi277
| 0.87564
0.83851

0.80137
0.76424

Command: |
Zoom: 1.0x

Nodes: 10252, Elements: 10000

Render: Smooth

|
+ 4 (mf »
i

(43999 ,-25.358 ,0) Post
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Post-traitement

En comparant les cartes de Froude, on note l'effet de la taille de la maille et du type
de solveur sur les résultats.

maillage fin, solveur

Roe ordre 2
|Frnuﬂ

1.0984
l 1.0613
# 1.0242

- 0.98703
- 0.9499
0.91277

. 0.87564

4 Io.53851
|\ 0.80137
x 0.76424
Hydraulic, step 120
Smooth Contour Fill ( Mean) of Froude, |Froude|.

Yber

maillage grossier,
solveur Roe ordre 1

|Froude|
1.168
I 1.1446
N 1.1212
1.0978
-1.0743
1.0509
- 1.0275
1.0041
0.9807
0.9573

Hydraulic, step 120

Smooth Contour Fill ( Mean) of Froude, |Froude|. Yber
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